On Sun, Mar 1, 2015 at 9:42 PM, Joe Perches <joe@xxxxxxxxxxx> wrote: > On Sun, 2015-03-01 at 21:31 +0200, Emmanuel Grumbach wrote: >> From: Eyal Shapira <eyal@xxxxxxxxxx> >> >> Add this to the info printed when reading rate_scale_table. >> Useful for debugging. > [] >> diff --git a/drivers/net/wireless/iwlwifi/mvm/rs.c b/drivers/net/wireless/iwlwifi/mvm/rs.c > [] >> @@ -3369,6 +3370,16 @@ static ssize_t rs_sta_dbgfs_scale_table_read(struct file *file, >> lq_sta->lq.agg_frame_cnt_limit); >> >> desc += sprintf(buff+desc, "reduced tpc=%d\n", lq_sta->lq.reduced_tpc); >> + ss_params = le32_to_cpu(lq_sta->lq.ss_params); >> + desc += sprintf(buff+desc, "single stream params: %s%s%s%s\n", >> + (ss_params & LQ_SS_PARAMS_VALID) ? >> + "VALID," : "INVALID", >> + (ss_params & LQ_SS_BFER_ALLOWED) ? >> + "BFER," : "", >> + (ss_params & LQ_SS_STBC_1SS_ALLOWED) ? >> + "STBC," : "", >> + (ss_params & LQ_SS_FORCE) ? >> + "FORCE" : ""); > > Are all things exclusive? INVALID is exclusive to the other options so there's no real readability issue. I like your version better though as it avoids the additional comma in the end. Submitted to Emmanuel's internal tree. Thanks > If no, the output is not easily readable. > > It would probably be better to use: > 12345678901234567890123456789012345678901234567890123456789012345678901234567890 > desc += sprintf(buff+desc, "single stream params: %s%s%s%s\n", > (ss_params & LQ_SS_PARAMS_VALID) ? > "VALID" : "INVALID", > (ss_params & LQ_SS_BFER_ALLOWED) ? > ", BFER" : "", > (ss_params & LQ_SS_STBC_1SS_ALLOWED) ? > ", STBC" : "", > (ss_params & LQ_SS_FORCE) ? > ", FORCE" : ""); > -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html