Johannes Berg <johannes@xxxxxxxxxxxxxxxx> writes: > +void cfg80211_report_rate_stats(struct wiphy *wiphy, struct wireless_dev *wdev, > + const u8 *addr, unsigned int n_stats, > + struct cfg80211_rate_stats *stats, gfp_t gfp); > + > /* ethtool helper */ > void cfg80211_get_drvinfo(struct net_device *dev, struct ethtool_drvinfo *info); > > diff --git a/include/uapi/linux/nl80211.h b/include/uapi/linux/nl80211.h > index f52797a90816..d03e3caef505 100644 > --- a/include/uapi/linux/nl80211.h > +++ b/include/uapi/linux/nl80211.h > @@ -35,6 +35,7 @@ > #define NL80211_MULTICAST_GROUP_MLME "mlme" > #define NL80211_MULTICAST_GROUP_VENDOR "vendor" > #define NL80211_MULTICAST_GROUP_TESTMODE "testmode" > +#define NL80211_MULTICAST_GROUP_RATESTATS "rate-stats" > > /** > * DOC: Station handling > @@ -796,6 +797,10 @@ > * as an event to indicate changes for devices with wiphy-specific regdom > * management. > * > + * @NL80211_CMD_GET_RATE_STATISTICS: This command can be used to trigger the So in a few lines we have all these phrases describing the same feature in different contexts (3 of which are different even after ignoring casing and _/- translation): rate_stats RATESTATS rate-stats RATE_STATISTICS How about sticking to one phrase to avoid having to look these up every time you use them? I don't care too much about which one it would be. But if I were to choose, I would have gone for the shortest one: RATESTATS. It also has the advantage that you don't need the _/- translation, which avoids another possible confusion. Bjørn -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html