On Wed, 2014-12-24 at 10:21 +0100, Lorenzo Bianconi wrote: > - list_for_each_entry(sdata, &local->interfaces, list) > + list_for_each_entry(sdata, &local->interfaces, list) { > sdata->user_power_level = local->user_power_level; > + if (!update_tpc && type != sdata->vif.bss_conf.txpower_type) > + update_tpc = true; Why bother checking - if it's already true then setting it to true won't matter, and IMHO makes the code easier to read. I also think "update_tpc" is a bad name - transmit power control is the actual usage here, but you really mean "update_txp_type" or so. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html