On Mon, 2014-10-27 at 12:44 +0200, Jukka Rissanen wrote: > +static void mcast_msg(struct sk_buff *mcast_skb, struct genl_info *info) > +{ > + if (info) > + genl_notify(&hwsim_genl_family, mcast_skb, > + genl_info_net(info), info->snd_portid, > + HWSIM_MCGRP_CONFIG, info->nlhdr, GFP_KERNEL); > + else > + genlmsg_multicast(&hwsim_genl_family, mcast_skb, 0, > + HWSIM_MCGRP_CONFIG, GFP_KERNEL); > +} Also - given the parameters and what this does, that's a bad name for the function. Never mind that it doesn't have any sort of identifier (say hwsim_ prefix), it doesn't even do what it says it does. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html