On 3 June 2014 21:40, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > On Thu, 2014-05-29 at 08:38 +0200, Michal Kazior wrote: > > >> + memcpy(new->csa_counter_offsets, >> csa->counter_offsets_beacon, >> + csa->n_counter_offsets_beacon * >> + sizeof(*new->csa_counter_offsets)); > > Given that it's used like an array, maybe > sizeof(new->csa_counter_offsets[0]) would be more readable? (this is in > a few places) I can update that. >> +++ b/net/mac80211/ibss.c >> @@ -143,7 +143,7 @@ ieee80211_ibss_build_presp(struct ieee80211_sub_if_data *sdata, >> *pos++ = csa_settings->block_tx ? 1 : 0; >> *pos++ = ieee80211_frequency_to_channel( >> csa_settings->chandef.chan->center_freq); >> - sdata->csa_counter_offset_beacon[0] = (pos - presp->head); >> + presp->csa_counter_offsets[0] = (pos - presp->head); > > This seems slightly odd, but maybe it's a bugfix? Or are presp/beacon > actually identical? It seems presp is used when building beacon for ibss. See __ieee80211_beacon_get(). Michał -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html