On 03/24/2014 04:21 AM, Michal Kazior wrote: > On 24 March 2014 12:12, Kalle Valo <kvalo@xxxxxxxxxxxxxxxx> wrote: >>> - status = ath10k_htc_send(htc, ATH10K_HTC_EP_0, skb); >>> + status = ath10k_htc_send(htc, ATH10K_HTC_EP_0, skb, __LINE__); >> >> Using line numbers in debug messages is very cumbersome. Some people >> cherry pick patches, have their own changes and whatnot which will make >> it more difficult to read the debug logs. Isn't there any better way to >> do this? > > I would prefer to explicitly wait for tx credit replenishment in > ath10k_wmi_cmd_send() after a command is sent instead of all these > prints. This way you can get a full call trace if it times out. Would that be a performance problem (by effectively allowing only a single item to be sent to the firmware at any given time?) Thanks, Ben -- Ben Greear <greearb@xxxxxxxxxxxxxxx> Candela Technologies Inc http://www.candelatech.com -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html