Hi, On Sat, Jan 18, 2014 at 12:11:56AM +0100, Linus Walleij wrote: > On Fri, Jan 17, 2014 at 6:43 PM, Chen-Yu Tsai <wens@xxxxxxxx> wrote: > > On Sat, Jan 18, 2014 at 12:47 AM, Arnd Bergmann <arnd@xxxxxxxx> wrote: > > >>> +- NAME_shutdown-gpios : GPIO phandle to shutdown control > >>> + (phandle must be the second) > >>> +- NAME_reset-gpios : GPIO phandle to reset control > >>> + > >>> +NAME must match the rfkill-name property. NAME_shutdown-gpios or > >>> +NAME_reset-gpios, or both, must be defined. > >>> + > >> > >> I don't understand this part. Why do you include the name in the > >> gpios property, rather than just hardcoding the property strings > >> to "shutdown-gpios" and "reset-gpios"? > > > > This quirk is a result of how gpiod_get_index implements device tree > > lookup. > > Why can't it just have a single property "gpios", where the first > element is the reset GPIO and the second is the shutdown GPIO? > > rfkill-gpio does this: > > gpio = devm_gpiod_get_index(&pdev->dev, rfkill->reset_name, 0); > gpio = devm_gpiod_get_index(&pdev->dev, rfkill->shutdown_name, 1); > > The passed con ID name parameter is only there for the device > tree case it seems. (ACPI ignores it.) So what about you just > don't pass it at all and patch it to do like this instead: > > gpio = devm_gpiod_get_index(&pdev->dev, NULL, 0); > gpio = devm_gpiod_get_index(&pdev->dev, NULL, 1); > > Heikki, are you OK with this change? Yes, definitely. That is much cleaner. Thanks, -- heikki -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html