On Wed, 2013-11-13 at 19:47 +0200, Luciano Coelho wrote: > Refactor ieee80211_mesh_process_chanswitch() to use > ieee80211_channel_switch() and avoid code duplication. > > Signed-off-by: Luciano Coelho <luciano.coelho@xxxxxxxxx> > --- [...] > diff --git a/net/mac80211/ieee80211_i.h b/net/mac80211/ieee80211_i.h > index f4af05d..bba7897 100644 > --- a/net/mac80211/ieee80211_i.h > +++ b/net/mac80211/ieee80211_i.h > @@ -612,6 +612,7 @@ struct ieee80211_if_mesh { > /* Channel Switching Support */ > struct mesh_csa_settings __rcu *csa; > bool chsw_init; > + bool csa_repeater; These two booleans are mutually exclusive, so they should probably be combined in an enumeration to avoid confusion. I'll send v5 with this change. -- Cheers, Luca. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html