Hi Daniel, > Hmm. Now that I heard back from you and Bing, that interrupts at this > point are totally unexpected, I would prefer to see the interrupt > handler being disabled at the appropriate time, I think we can do > better than my original patch. Let me see if I can find some time > today/tomorrow to explore a better approach. >What about this one? The patch looks fine to me. Some comments 1) Unused HOST_INT_DISABLE macro can be removed now. 2) if_ops.disable_int() should be called before if_ops.unregister_dev() even in driver load failure code path. Otherwise we will miss to release sdio irq in this case. (You can consider applying attached changes on top of your patch for (1) and (2)) 3) Previously we used to have error handling for sdio_claim_irq(). Now we should check return status of if_ops.enable_int(). As I have couple of other patches to handle driver load failure paths correctly, I will take care of this separately. 4) I will create separate patch to avoid forward declaration of mwifiex_sdio_interrupt() by moving some code. Regards, Amitkumar Karwar
Attachment:
minor_corrections.diff
Description: minor_corrections.diff