On Fri, 2012-11-23 at 12:18 -0800, Marco Porsch wrote: > +/** > + * ieee80211_has_qos_pm - check Power Save Level in QoS control > + * @qc - QoS control bytes in little-endian byteorder > + */ > +static inline bool ieee80211_has_qos_pm(__le16 qc) > +{ > + return (qc & cpu_to_le16(IEEE80211_QOS_CTL_MESH_PS_LEVEL)) != 0; I think this is confusing. Why not call it "has_qos_mesh_ps" or something? johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html