> > +enum ieee80211_ampdu_mlme_flags { > > + IEEE80211_AMPDU_RX_START = 1<<0, > > + IEEE80211_AMPDU_RX_STOP = 1<<1, > > +}; > > Can both really happen at the same time? Or why are they flags rather > than just an action code? Ok, looking at the rest of the code, they do not happen together. But thanks for splitting up the patches anyway, it does make things more readable. Please just remove the numbers completely, rename it to enum ieee80211_apmdu_mlme_action and use "enum ieee80211_ampdu_mlme_action action" instead of "u8 action" in the apmdu_action callback. johannes
Attachment:
signature.asc
Description: This is a digitally signed message part