On Sunday 09 December 2007 07:33:42 Ron Rindjunsky wrote: > This patch fixes should_drop_frame function to pass in ps poll control > frames required for power save functioanlity. Interface types that do not > have interest for PS POLL frames now drop it in handler. > > Signed-off-by: Ron Rindjunsky <ron.rindjunsky@xxxxxxxxx> > --- > net/mac80211/ieee80211_i.h | 5 +++++ > net/mac80211/rx.c | 10 ++++++++-- > net/mac80211/util.c | 6 +++++- > 3 files changed, 18 insertions(+), 3 deletions(-) > > diff --git a/net/mac80211/ieee80211_i.h b/net/mac80211/ieee80211_i.h > index 2476cc5..a7746da 100644 > --- a/net/mac80211/ieee80211_i.h > +++ b/net/mac80211/ieee80211_i.h > @@ -58,6 +58,11 @@ struct ieee80211_local; > * increased memory use (about 2 kB of RAM per entry). */ > #define IEEE80211_FRAGMENT_MAX 4 > > +/* IEEE 80211.11 minimal headers length */ One too many '11's in there. > +#define IEEE80211_HDR_MIN_LEN_CTRL 16 > +#define IEEE80211_HDR_MIN_LEN_DATA 24 > +#define IEEE80211_HDR_MIN_LEN_MGMT 24 > + This isn't really related to fixing the PS_POLL frame passing. It's a good idea however - please put it in include/linux/ieee80211.h and follow the naming conventions there. Otherwise looks fine. Thanks, -Michael Wu
Attachment:
signature.asc
Description: This is a digitally signed message part.