> Agreed about filename length. I would prefer not to make mesh > networking configurable, as STA, IBSS, etc modes aren't configurable > either. I prefer to avoid polluting the data path with ifdefs. Ok, I'm not sure, it just seems like quite a bit of code especially when all the other features will be added, something people like the OpenWRT folks might not like. nbd? > Mesh APs are not supported yet, but we plan to support them through a > different interface type (e.g. ..._TYPE_MAP) or extending the AP > interface type. Mesh STAs and APs will share all the mesh-specific > stuff (peer link discovery, path discovery, etc) but they have little > in common in the data path, so I do not think it makes sense to use > the same interface type for both. Maybe I should rename ..IF_TYPE_MESH > to ..IF_TYPE_MESH_STA? Probably. Come to think of it, how much mesh networking is actually done by the mesh AP? I guess we need to support this in hostapd rather than the kernel? > > > +static void ieee80211_mesh(struct net_device *dev, > > > + struct ieee80211_if_sta *ifsta) > > > +{ > > > + mod_timer(&ifsta->timer, jiffies + IEEE80211_MONITORING_INTERVAL); > > > +} > > > > ?? That needs a better name, whatever it does. > > Well, doesn't really do anything yet, I can rename it to > ieee80211_mesh_housekeeping, which is the function it will perform > soon. Hmm, ok. I'll take another look then. "housekeeping" sounds far too generic though, so at least if it's named that way it should call other functions IMHO. > It would be ((rx->fc & (FROMDS|TODS)) == (FROMDS|TODS)). Given the > length of 'FROMDS' and 'TODS' actual macros, I would leave it as it is > or add a new definition IEEE80211_FCTL_WDS = (FROMDS|TODS) and use > that. Yeah, I know they're pretty long, but the ! in there confused me. I think it's fine if you indent the second line one space more to indicate that it belongs into the !( parenthesis. johannes
Attachment:
signature.asc
Description: This is a digitally signed message part