On Friday 05 October 2007 16:03:24 Johannes Berg wrote: > On Fri, 2007-10-05 at 15:56 +0200, Michael Buesch wrote: > > What is the get_sequence_counter callback for? > > > > /* For devices that have internal sequence counters, allow 802.11 > > * code to access the current value of a counter */ > > int (*get_sequence_counter)(struct ieee80211_hw *hw, > > u8* addr, u8 keyidx, u8 txrx, > > u32* iv32, u16* iv16); > > > > It doesn't seem to be used in current mac80211 code. > > It seems that this is to fetch the current initial values. > > Is that correct? > > Who is supposed to use this callback? If it's unused, let's remove > > it please. The documentation for it sucks anyway. :) > > No, it's actually used in a patch I'm about to post: > http://johannes.sipsolutions.net/patches/kernel/all/2007-09-28-22%3a38/017-mac80211-key-seq-nl80211.patch > > Mind you, it could be renamed and described better; it's used for > getting the current sequence number of a hardware TKIP implementation. Ah, ok. It sounded to me like it's supposed to fetch the seq_ctrl counter (data header), if the device does frame sequence counting in hw. Can you please rename that to something like get_tkip_ivs() or get_tkip_counters() or something like that? -- Greetings Michael. - To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html