On Tue, Nov 14, 2023 at 11:13 AM Jason Wang <jasowang@xxxxxxxxxx> wrote: > > On Sat, Nov 11, 2023 at 6:18 AM Shannon Nelson <shannon.nelson@xxxxxxx> wrote: > > > > Fix up the order that the device and negotiated features > > are checked to get a more reliable difference when things > > get changed. > > > > Signed-off-by: Shannon Nelson <shannon.nelson@xxxxxxx> > > --- > > drivers/vdpa/pds/vdpa_dev.c | 3 +-- > > 1 file changed, 1 insertion(+), 2 deletions(-) > > > > diff --git a/drivers/vdpa/pds/vdpa_dev.c b/drivers/vdpa/pds/vdpa_dev.c > > index 9fc89c82d1f0..25c0fe5ec3d5 100644 > > --- a/drivers/vdpa/pds/vdpa_dev.c > > +++ b/drivers/vdpa/pds/vdpa_dev.c > > @@ -318,9 +318,8 @@ static int pds_vdpa_set_driver_features(struct vdpa_device *vdpa_dev, u64 featur > > return -EOPNOTSUPP; > > } > > > > - pdsv->negotiated_features = nego_features; > > - > > driver_features = pds_vdpa_get_driver_features(vdpa_dev); > > + pdsv->negotiated_features = nego_features; > > I may miss something, but I don't see how things have changed here. Ok, I think I get it. driver_feautres here means the old negotiated features. We probably need a better name (not a native speaker though). Acked-by: Jason Wang <jasowang@xxxxxxxxxx> Thanks > > Thanks > > > dev_dbg(dev, "%s: %#llx => %#llx\n", > > __func__, driver_features, nego_features); > > > > -- > > 2.17.1 > >