On Thu, Feb 2, 2023 at 3:25 PM Mike Christie <michael.christie@xxxxxxxxxx> wrote: > > + if (args->worker_flags & USER_WORKER_SIG_IGN) > + ignore_signals(p); Same comment as for the other case. There are real reasons to avoid bitfields: - you can't pass addresses to them around - it's easier to read or assign multiple fields in one go - they are horrible for ABI issues due to the exact bit ordering and padding being very subtle but none of those issues are relevant here, where it's a kernel-internal ABI. All these use-cases seem to actually be testing one bit at a time, and the "assignments" are structure initializers for which named bitfields are actually perfect and just make the initializer more legible. Linus _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linuxfoundation.org/mailman/listinfo/virtualization