On Thu, Apr 14, 2022 at 05:08:53PM +0200, Christophe de Dinechin wrote: > With gcc version 12.0.1 20220401 (Red Hat 12.0.1-0) (GCC), the following > errors are reported in sched.h when building after `make defconfig`: <snip tons of noise> > Rewrite the definitions of sched_class_highest and for_class_range to > avoid this error as follows: > > 1/ The sched_class_highest is rewritten to be relative to > __begin_sched_classes, so that GCC sees it as being part of the > __begin_sched_classes array and not a distinct __end_sched_classes > array. > > 2/ The for_class_range macro is modified to replace the comparison with > an out-of-bound pointer __begin_sched_classes - 1 with an equivalent, > but in-bounds comparison. > > In that specific case, I believe that the GCC analysis is correct and > potentially valuable for other arrays, so it makes sense to keep it > enabled. > > Signed-off-by: Christophe de Dinechin <christophe@xxxxxxxxxxxx> > Signed-off-by: Christophe de Dinechin <dinechin@xxxxxxxxxx> > --- > kernel/sched/sched.h | 11 +++++++++-- > 1 file changed, 9 insertions(+), 2 deletions(-) > > diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h > index 8dccb34eb190..6350fbc7418d 100644 > --- a/kernel/sched/sched.h > +++ b/kernel/sched/sched.h > @@ -2193,11 +2193,18 @@ const struct sched_class name##_sched_class \ > extern struct sched_class __begin_sched_classes[]; > extern struct sched_class __end_sched_classes[]; > > -#define sched_class_highest (__end_sched_classes - 1) > +/* > + * sched_class_highests is really __end_sched_classes - 1, but written in a way > + * that makes it clear that it is within __begin_sched_classes[] and not outside > + * of __end_sched_classes[]. > + */ > +#define sched_class_highest (__begin_sched_classes + \ > + (__end_sched_classes - __begin_sched_classes - 1)) > #define sched_class_lowest (__begin_sched_classes - 1) > > +/* The + 1 below places the pointers within the range of their array */ > #define for_class_range(class, _from, _to) \ > - for (class = (_from); class != (_to); class--) > + for (class = (_from); class + 1 != (_to) + 1; class--) Urgh, so now we get less readable code, just because GCC is being stupid? What's wrong with negative array indexes? memory is memory, stuff works. _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linuxfoundation.org/mailman/listinfo/virtualization