On Thu, Nov 11, 2010 at 01:03:10PM -0700, Ky Srinivasan wrote: > +/* > + * Array of keys we support in Linux. Not really, you can support "any" number of keys as the kernel shouldn't care, or did I get it wrong? > + * > + */ > +#define KVP_MAX_KEY 10 > +#define KVP_LIC_VERSION 1 Um, this is a nice magic number, care to explain it a bit more? > +static char *kvp_keys[KVP_MAX_KEY] = {"FullyQualifiedDomainName", > + "IntegrationServicesVersion", Looks like it matches up with this, right? You might want to make that a bit more "tied" together. > + case (KVP_LIC_VERSION): > + kvp_transaction_active = true; > + kvp_respond_to_host(kvp_data->index, > + HV_DRV_VERSION); Why are you doing this in the kernel? Why not do it from userspace like all other messages? thanks, greg k-h _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/virtualization