On Fri, 2007-09-21 at 12:48 +0200, Christian Borntraeger wrote: > Am Donnerstag, 20. September 2007 schrieb Rusty Russell: > > The network driver uses *two* virtqueues: one for input packets and > > one for output packets. This has nice locking properties (ie. we > > don't do any for recv vs send). > [...] > > 3) Resolve freeing of old xmit skbs (someone sent patch IIRC?) > > Yes, that was me. I am quite busy at the moment but I will send a refreshed > patch soon. The most annoying fact of my current patch is, that I have to add > locking. (Because of the only one operation per virtqueue at a time rule) Sorry Christian, I thought it was you but was in a hurry to send out the patches so didn't go back and check. Can't we just re-use the default xmit lock? > [...] > > +struct virtnet_info > > +{ > > + struct virtqueue_ops *vq_ops; > > + struct virtqueue *vq_recv; > > + struct virtqueue *vq_send; > > + struct net_device *ndev; > > This is only a matter of taste, but I like netdev or dev more than ndev. Yeah, I agreed. It was a moment of weakness: I've renamed it to "dev". Thanks! Rusty. _______________________________________________ Virtualization mailing list Virtualization@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/virtualization