* Jeremy Fitzhardinge <jeremy at goop.org> wrote: > > Yes. vmalloc would have the annoying side-effect of actually > > allocating some pages which would be shadowed by the remapping, but > > I guess get_vm_area would do the job. I'll give it a go. > > Hm, this is a bit awkward. We need to map the shared info page fairly > early - say, around paging_init - but we're still on the bootmem > allocator at that point, so get_vm_area isn't usable yet. Using a > fixmap keeps things simple. It seems to me that having a single > fixmap available is useful for this kind of simple/early mapping, and > if someone needs to map something larger, then they can put it off > until get_vm_area() is available... fair enough. Please rename it to FIX_PARAVIRT_BOOTUP - you can still rely on it being available later on too, but we'd like to give everyone the right fundamental idea about this: it's meant to be a limited, inflexible interface for bootstrap only. Ingo