On Tue, May 09, 2006 at 12:00:32AM -0700, Chris Wright wrote: > +EXPORT_SYMBOL_GPL(alloc_vm_area); > +EXPORT_SYMBOL_GPL(free_vm_area); > +EXPORT_SYMBOL_GPL(lock_vm_area); > +EXPORT_SYMBOL_GPL(unlock_vm_area); These are all pretty generic function names. Perhaps they belong in the core kernel code instead of a Xen specific file? thanks, greg k-h