/* fall through */ > --- linus-2.6.orig/include/asm-i386/mach-default/mach_system.h > +++ linus-2.6/include/asm-i386/mach-default/mach_system.h > @@ -1,6 +1,8 @@ > #ifndef __ASM_MACH_SYSTEM_H > #define __ASM_MACH_SYSTEM_H > > +#define clearsegment(seg) I don't think you can give such a specific hook such a generic name. I would just add an ifdef around the real user with a comment. -Andi