* Zachary Amsden <zach@xxxxxxxxxx> wrote: > +#define get_desc_32bit(desc) (((desc)->b >> 22) & 1) > +#define get_desc_contents(desc) (((desc)->b >> 10) & 3) > +#define get_desc_writable(desc) (((desc)->b >> 9) & 1) > +#define get_desc_gran(desc) (((desc)->b >> 23) & 1) > +#define get_desc_present(desc) (((desc)->b >> 15) & 1) > +#define get_desc_usable(desc) (((desc)->b >> 20) & 1) naming nit: shouldnt they be 'desc_32bit()/desc_writable()/...'? No need for the get_ i think. Ingo