[RFC v2 0/4] remove unnecessary code related to MMIO reads/writes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Changes from v1:
  * create one patch per type of conversion instead of multiple patches
    associated with specific xhci files
  * change commit messages to be more readable and to reflect the above change
  * add an empty line between #include <asm-generic/io-64-nonatomic-lo-hi.h>
    and the rest of the headers to improve readability.

Xenia Ragiadakou (4):
  xhci: replace xhci_readl() with readl()
  xhci: replace xhci_writel() with writel()
  xhci: replace xhci_read_64() with readq()
  xhci: replace xhci_write_64() with writeq()

 drivers/usb/host/xhci-dbg.c  |  42 ++++++------
 drivers/usb/host/xhci-hub.c  | 106 ++++++++++++++---------------
 drivers/usb/host/xhci-mem.c  |  40 +++++------
 drivers/usb/host/xhci-ring.c |  34 +++++-----
 drivers/usb/host/xhci.c      | 157 +++++++++++++++++++++----------------------
 drivers/usb/host/xhci.h      |  52 +++-----------
 6 files changed, 196 insertions(+), 235 deletions(-)

-- 
1.8.3.4

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux