Fix the return value of uhci_hub_control() to reflect the length of copied buffer. Remove the OK macro for that function to make code more readable. This series also contains hardcoding-to-macro changes in uhci-debug.c. CHANGES: ---------- v2 - v1: o Do the bugfix in uhci_hub_control() in addition to the OK macro removal. ---------- Deng-Cheng Zhu (2): USB/host: Use existing macros instead of hard-coded values in uhci-debug.c USB/host: Bugfix: Return length of copied buffer in uhci_hub_control() drivers/usb/host/uhci-debug.c | 16 ++++++++-------- drivers/usb/host/uhci-hub.c | 40 ++++++++++++++++++++-------------------- 2 files changed, 28 insertions(+), 28 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html