On Wed, Jun 06, 2012 at 12:39:55PM +0300, Alexander Shishkin wrote: > Richard Zhao <richard.zhao@xxxxxxxxxxxxx> writes: > > > It still has below limitations: > > - it does not work for multi-phy ehci > > - the best place is after debounce, but I can't get > > phy there > > > > Signed-off-by: Richard Zhao <richard.zhao@xxxxxxxxxxxxx> > > --- > > drivers/usb/host/ehci-hcd.c | 15 +++++++++++++++ > > 1 files changed, 15 insertions(+), 0 deletions(-) > > > > diff --git a/drivers/usb/host/ehci-hcd.c b/drivers/usb/host/ehci-hcd.c > > index b100f5f..724ac471 100644 > > --- a/drivers/usb/host/ehci-hcd.c > > +++ b/drivers/usb/host/ehci-hcd.c > > @@ -928,6 +928,21 @@ static irqreturn_t ehci_irq (struct usb_hcd *hcd) > > pstatus = ehci_readl(ehci, > > &ehci->regs->port_status[i]); > > > > + /* FIXME: > > + * - it does not work for multi-phy ehci > > + * - the best place is after debounce, but I can't get > > + * phy there > > + */ > > + if (unlikely(ehci->transceiver && > > + (pstatus & PORT_CSC))) { > > I don't think you need parens around (pstatus & PORT_CSC), since it > should already have higher precedence. But it's more readable. Isn't it? Thanks Richard -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html