Re: [PATCH 2/2] ohci-da8xx: set MODULE_ALIAS to allow autoloading

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 7 May 2012, Jan Luebbe wrote:

> The Davinci USB platform device (in mach-davinci/usb.c) uses "ohci"
> as the name. To allow autoloading of the relevant driver, the module
> needs to set the MODULE_ALIAS.
> 
> Signed-off-by: Jan Luebbe <jlu@xxxxxxxxxxxxxx>
> ---
>  drivers/usb/host/ohci-da8xx.c |    2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/drivers/usb/host/ohci-da8xx.c b/drivers/usb/host/ohci-da8xx.c
> index 8435097..269b1e0 100644
> --- a/drivers/usb/host/ohci-da8xx.c
> +++ b/drivers/usb/host/ohci-da8xx.c
> @@ -454,3 +454,5 @@ static struct platform_driver ohci_hcd_da8xx_driver = {
>  		.name	= "ohci",
>  	},
>  };
> +
> +MODULE_ALIAS("platform:ohci");

Patches like this should be sent directly to the USB maintainer,
Greg KH.

Alan Stern

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux