[PATCH 00/10] Misc patches

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Paul,

here's most of your patches. I'm only missing the hibernation
code itself.

I have splitted your patches into smaller versions of themselves
so it's easier to review and apply. The hibernation code is still
a giant beast which I will treat more carefuly.

I would like to send these patches on v3.5 merge window, can you
make sure they are still correct ?

Paul Zimmerman (10):
  usb: dwc3: add definitions for new registers
  usb: dwc3: gadget: reinitialize retries
  usb: dwc3: gadget: rename phy_power() to phy_suspend()
  usb: dwc3: support new revisions of DWC3 core
  usb: dwc3: gadget: implement dwc3_gadget_get_link_state
  usb: dwc3: add 'saved_state' field to dwc3_ep structure
  usb: dwc3: gadget: re-factor dwc3_gadget_start
  usb: dwc3: gadget: add 'restore' parameter to endpoint handling
  usb: dwc3: gadget: add 'force' argument to stop_active_transfer
  usb: dwc3: core: make sure evt->lpos is correctly initialized

 drivers/usb/dwc3/core.c   |    7 +-
 drivers/usb/dwc3/core.h   |  114 ++++++++++++++++-----
 drivers/usb/dwc3/gadget.c |  247 +++++++++++++++++++++++++++++++++------------
 drivers/usb/dwc3/gadget.h |    6 ++
 4 files changed, 280 insertions(+), 94 deletions(-)

-- 
1.7.10

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux