[PATCH 04/13] usb: renesas_usbhs: modify function name of usbhs_set_device_xx()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



it was device configuration setting function, not only speed.
This patch modify function name usbhs_set_device_speed() -> usbhs_set_device_config()

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@xxxxxxxxxxx>
---
 drivers/usb/renesas_usbhs/common.c   |    2 +-
 drivers/usb/renesas_usbhs/common.h   |    2 +-
 drivers/usb/renesas_usbhs/mod_host.c |    4 ++--
 3 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/usb/renesas_usbhs/common.c b/drivers/usb/renesas_usbhs/common.c
index 0fea6b6..016a34f 100644
--- a/drivers/usb/renesas_usbhs/common.c
+++ b/drivers/usb/renesas_usbhs/common.c
@@ -219,7 +219,7 @@ static void usbhsc_bus_init(struct usbhs_priv *priv)
 /*
  *		device configuration
  */
-int usbhs_set_device_speed(struct usbhs_priv *priv, int devnum,
+int usbhs_set_device_config(struct usbhs_priv *priv, int devnum,
 			   u16 upphub, u16 hubport, u16 speed)
 {
 	struct device *dev = usbhs_priv_to_dev(priv);
diff --git a/drivers/usb/renesas_usbhs/common.h b/drivers/usb/renesas_usbhs/common.h
index e255015..71c295c 100644
--- a/drivers/usb/renesas_usbhs/common.h
+++ b/drivers/usb/renesas_usbhs/common.h
@@ -306,7 +306,7 @@ int usbhs_frame_get_num(struct usbhs_priv *priv);
 /*
  * device config
  */
-int usbhs_set_device_speed(struct usbhs_priv *priv, int devnum, u16 upphub,
+int usbhs_set_device_config(struct usbhs_priv *priv, int devnum, u16 upphub,
 			   u16 hubport, u16 speed);
 
 /*
diff --git a/drivers/usb/renesas_usbhs/mod_host.c b/drivers/usb/renesas_usbhs/mod_host.c
index a13f530..598eecb 100644
--- a/drivers/usb/renesas_usbhs/mod_host.c
+++ b/drivers/usb/renesas_usbhs/mod_host.c
@@ -317,7 +317,7 @@ usbhsh_device_find:
 	udev->usbv = usbv;
 
 	/* set device config */
-	usbhs_set_device_speed(priv,
+	usbhs_set_device_config(priv,
 			       usbhsh_device_number(hpriv, udev),
 			       usbhsh_device_number(hpriv, udev),
 			       0, /* FIXME no parent */
@@ -433,7 +433,7 @@ usbhsh_endpoint_alloc_find_pipe:
 
 	/*
 	 * usbhs_pipe_config_update() should be called after
-	 * usbhs_device_config()
+	 * usbhs_set_device_config()
 	 * see
 	 *  DCPMAXP/PIPEMAXP
 	 */
-- 
1.7.5.4

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux