2011/5/4 Joe Perches <joe@xxxxxxxxxxx>: > On Wed, 2011-05-04 at 15:35 +0400, Sergei Shtylyov wrote: >> Hello. > > And hello to you Sergei. > > On 03-05-2011 22:17, Joe Perches wrote: >> > Use the more standard logging form. >> > Add a bit more tidying style. >> Â Â Style changes look rather doubtful to me... >> > Â drivers/net/usb/usbnet.c | Â 23 +++++++++++------------ >> > diff --git a/drivers/net/usb/usbnet.c b/drivers/net/usb/usbnet.c > [] >> > @@ -192,8 +192,8 @@ static int init_status(struct usbnet *dev, struct usb_interface *intf) >> > Â Â Â Â Â Â return 0; >> > >> > Â Â pipe = usb_rcvintpipe(dev->udev, >> > - Â Â Â Â Â Â Â Â Â Â Â Â dev->status->desc.bEndpointAddress >> > - Â Â Â Â Â Â Â Â Â & USB_ENDPOINT_NUMBER_MASK); >> > + Â Â Â Â Â Â Â Â Â Â Â Â (dev->status->desc.bEndpointAddress >> > + Â Â Â Â Â Â Â Â Â & USB_ENDPOINT_NUMBER_MASK)); >> >> Â Â Why add parens? > > Leading & uses are almost always addressof. > This makes it easier for me to see that it's not an addressof use. This is a clear case where 80-char limit impairs code readability. Why not just use another variable? int epn = dev->status->desc.bEndpointAddress & USB_ENDPOINT_NUMBER_MASK; pipe = usb_rcvintpipe(dev->udev, epn); Best Regards, MichaÅ MirosÅaw -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html