On Thu, 30 Dec 2010, Sarah Sharp wrote: > The xHCI driver essentially has both a USB 2.0 and a USB 3.0 roothub. So > setting the HCD_USB3 bits in the hcd->driver->flags is a bit misleading. > Add a new field to usb_hcd, bcdUSB. Store the result of > hcd->driver->flags & HCD_MASK in it. Later, when we have the xHCI driver > register the two roothubs, we'll set the usb_hcd->bcdUSB field to HCD_USB2 > for the USB 2.0 roothub, and HCD_USB3 for the USB 3.0 roothub. This new field shouldn't be called "bcdUSB" unless it actually uses the same binary-coded-decimal format as the bcdUSB field in the USB spec. Since the HCD_USBx values aren't in this format, the new field should be called something like "usb_version". Alan Stern -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html