Hi,
On Tue, Dec 07, 2010 at 04:03:19PM +0300, Sergei Shtylyov wrote:
@@ -88,6 +88,7 @@ struct am35x_glue {
struct clk *phy_clk;
struct clk *clk;
};
+#define glue_to_musb(g) platform_get_drvdata(g->musb)
Why get platfrom data of you already have 'musb' pointer, 'g->musb'?
Ah, that's 'struct platform_device *musb' -- I got muddled up by
naming... :-)
couldn't find a better name :-p I thought about musb_pdev, but that's
already too big and I'll add DMA there too for 2.6.39 merge window.
+#ifdef CONFIG_PM
+static int am35x_suspend(struct device *dev)
+{
+ struct am35x_glue *glue = dev_get_drvdata(dev);
+ struct musb *musb = glue_to_musb(musb);
Argument to the macro should be 'glue'.
+
+ phy_off();
+ clk_disable(glue->phy_clk);
+ clk_disable(glue->clk);
+
+ return 0;
+}
+
+static int am35x_resume(struct device *dev)
+{
+ struct am35x_glue *glue = dev_get_drvdata(dev);
+ struct musb *musb = glue_to_musb(musb);
Here too.
yeah, this was a problem when I rebased (and tried to fix quickly) the
branch is all fixed up.
--
balbi
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html