On Thu, Dec 02, 2010 at 06:13:16AM -0500, Mike Frysinger wrote:
On Thu, Dec 2, 2010 at 04:25, Felipe Balbi wrote:
--- a/drivers/usb/musb/blackfin.c
+++ b/drivers/usb/musb/blackfin.c
-void musb_platform_enable(struct musb *musb)
+static void bfin_enable(struct musb *musb)
-void musb_platform_disable(struct musb *musb)
+static void bfin_disable(struct musb *musb)
-void musb_platform_try_idle(struct musb *musb, unsigned long timeout)
+static void bfin_try_idle(struct musb *musb, unsigned long timeout)
personally, i dislike the removal of "musb" from the function names.
it makes kallsyms collisions much more likely and tracebacks in crash
messages not as obvious as it should be. if code crashes in
"bfin_enable", i now have to search the tree to find out where this
"bfin_enable" symbol is coming from. if it said "bfin_musb_enable",
i'd know immediately it's the musb driver.
i imagine this applies to all the arches here and not just Blackfin ...
that's simple enough change :-)
no problems there
--
balbi
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html