On Mon, Nov 22, 2010 at 5:32 PM, <chao.xie@xxxxxxxxxxx> wrote: > From: cxie4 <cxie4@xxxxxxxxxxx> > > Signed-off-by: Chao Xie <chao.xie@xxxxxxxxxxx> > --- > Âarch/arm/mach-mmp/pxa910.c | Â Â2 ++ > Â1 files changed, 2 insertions(+), 0 deletions(-) > > diff --git a/arch/arm/mach-mmp/pxa910.c b/arch/arm/mach-mmp/pxa910.c > index 46f2d69..cf7c71a 100644 > --- a/arch/arm/mach-mmp/pxa910.c > +++ b/arch/arm/mach-mmp/pxa910.c > @@ -111,6 +111,7 @@ static APBC_CLK(pwm3, PXA910_PWM3, 1, 13000000); > Âstatic APBC_CLK(pwm4, PXA910_PWM4, 1, 13000000); > > Âstatic APMU_CLK(nand, NAND, 0x01db, 208000000); > +static APMU_CLK(u2o, USB, 0x1b, 480000000); > > Â/* device and clock bindings */ > Âstatic struct clk_lookup pxa910_clkregs[] = { > @@ -123,6 +124,7 @@ static struct clk_lookup pxa910_clkregs[] = { > Â Â Â ÂINIT_CLKREG(&clk_pwm3, "pxa910-pwm.2", NULL), > Â Â Â ÂINIT_CLKREG(&clk_pwm4, "pxa910-pwm.3", NULL), > Â Â Â ÂINIT_CLKREG(&clk_nand, "pxa3xx-nand", NULL), > + Â Â Â INIT_CLKREG(&clk_u2o, NULL, "U2OCLK"), Normally, device name is more preferred than a name string. In this case, it will be 'pxa-u2o'. PS: the naming is a bit inconsistent in the patch follows, the name of the driver file is called mv_udc, but the device name is 'pxa-u2o'? > Â}; > > Âstatic int __init pxa910_init(void) > -- > 1.6.3.3 > > -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html