Re: [PATCH] usbfs: use simple_empty instead of opencoding it

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Oct 06, 2010 at 08:54:20PM +0200, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig <hch@xxxxxx>

This breaks the build :(

> Index: linux-2.6/drivers/usb/core/inode.c
> ===================================================================
> --- linux-2.6.orig/drivers/usb/core/inode.c	2010-10-06 20:10:58.122003960 +0200
> +++ linux-2.6/drivers/usb/core/inode.c	2010-10-06 20:13:00.626004658 +0200
> @@ -334,29 +334,6 @@ static int usbfs_create (struct inode *d
>  	return usbfs_mknod (dir, dentry, mode, 0);
>  }
>  
> -static inline int usbfs_positive (struct dentry *dentry)
> -{
> -	return dentry->d_inode && !d_unhashed(dentry);
> -}

This function is used by the fs_remove_file() function later on.  So,
shouldn't it stick around?

Care to fix this and resend?

thanks,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux