Hi Sarah, This is v6 of xHCI isoc patchset. Changelog from v5: 1. Refine handle_tx_event(), break it into smaller functions to increase readability. Also remove unnecessary print messages in the interrupt context. 2. Remove handle_td jump, use do-while clause instead. 3. Fix the urb_done bug. 4. Rename urb_free_priv() to xhci_urb_free_priv(). I have done 24 hours stress test with a USB3.0 HDD doing r/w operations, a USB2.0 hub plugged with a USB2.0 TV tuner broadcasting TV and a USB1.1 webcam running. Please note this patchset is based on your revert-link-trb branch, commit 5162708fc3c0. And you also need the allocate bigger ring for isoc endpoint patch to get the isoc devices running. Thanks, Andiry -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html