On Tue, Apr 27, 2010 at 10:11 AM, Anatolij Gustschin <agust@xxxxxxx> wrote: > Factor out common code for registering a FSL EHCI platform > device into new fsl_usb2_register_device() function. This > is done to avoid code duplication while adding code for > instantiating of MPC5121 dual role USB platform devices. > Then, the subsequent patch can use > for_each_compatible_node(np, NULL, "fsl,mpc5121-usb2-dr") { > ... > fsl_usb2_register_device(); > } > > Signed-off-by: Anatolij Gustschin <agust@xxxxxxx> > Cc: Kumar Gala <galak@xxxxxxxxxxxxxxxxxxx> > Cc: Grant Likely <grant.likely@xxxxxxxxxxxx> > --- > arch/powerpc/sysdev/fsl_soc.c | 231 +++++++++++++++++++--------------------- Hi Anatolij, Thanks for this work. However, I've got concerns. Forgive me for ragging on code that you didn't write, but this fsl_soc.c code for registering the USB device really doesn't belong here anymore. It should be part of the drivers/usb/host/ehci-fsl.c and the driver should do of-style binding (Which should be a lot easier if I manage to get the merge of platform bus and of_platform bus into 2.6.35). This patch series makes the fsl_soc.c code even more complicated, and scatters what is essentially driver code over even more places in the arch/powerpc tree. I'm really not keen on it being merged in this form. g. -- To unsubscribe from this list: send the line "unsubscribe linux-usb" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html