Re: [PATCH v2 2/2] usb: xhci: set page size to the xHCI-supported size

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, 13 Jan 2025 16:30:37 +0200, Niklas Neronin wrote:
> +static void xhci_hcd_page_size(struct xhci_hcd *xhci)
> +{
> +	u32 page_shift;
> +
> +	page_shift = readl(&xhci->op_regs->page_size) & XHCI_PAGE_SIZE_MASK;

If there is a v3 of this series coming for other reasons, I think it
would also make sense to rename this to simply 'page_size' or something
like that.

Shift suggests that it's the logarithm of page size, but it is not.

Regards,
Michal




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux