Re: [PATCH linux-next] usb: typec: tcpm: use max() to get higher value

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Sep 25, 2024 at 05:50:14PM +0530, R Sundar wrote:
> Use max() for better readability and to fix cocci warnings.
> 
> Reported-by: kernel test robot <lkp@xxxxxxxxx>
> Reported-by: Julia Lawall <julia.lawall@xxxxxxxx>
> Closes: https://lore.kernel.org/r/202409231009.2efXAh9b-lkp@xxxxxxxxx/
> Signed-off-by: R Sundar <prosunofficial@xxxxxxxxx>

Reviewed-by: Heikki Krogerus <heikki.krogerus@xxxxxxxxxxxxxxx>

> ---
> 
> Reported in linux repo.
> tree:   https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git master
> 
> cocci warnings: (new ones prefixed by >>)
> >> drivers/usb/typec/tcpm/tcpm.c:6356:20-21: WARNING opportunity for max()
> 
> vim +6356 drivers/usb/typec/tcpm/tcpm.c
> 
> compile-tested only.
> 
>  drivers/usb/typec/tcpm/tcpm.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/usb/typec/tcpm/tcpm.c b/drivers/usb/typec/tcpm/tcpm.c
> index fc619478200f..aac4de1d53a8 100644
> --- a/drivers/usb/typec/tcpm/tcpm.c
> +++ b/drivers/usb/typec/tcpm/tcpm.c
> @@ -7367,7 +7367,7 @@ static int tcpm_psy_get_input_power_limit(struct tcpm_port *port,
>  			src_mv = pdo_fixed_voltage(pdo);
>  			src_ma = pdo_max_current(pdo);
>  			tmp = src_mv * src_ma;
> -			max_src_uw = tmp > max_src_uw ? tmp : max_src_uw;
> +			max_src_uw = max(tmp, max_src_uw);
>  		}
>  	}
>  
> -- 
> 2.34.1

-- 
heikki




[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux