> @@ -7554,6 +7558,11 @@ static void r8156_hw_phy_cfg(struct r8152 *tp) > ((swap_a & 0x1f) << 8) | > ((swap_a >> 8) & 0x1f)); > } > + > + /* set intr_en[3] */ > + data = ocp_reg_read(tp, OCP_INTR_EN); > + data |= INTR_SPEED_FORCE; Which is more meaningful, set intr_en[3], or data |= INTR_SPEED_FORCE I would say the second. The code is now pretty readable, it says what it is doing. So if you want to add a comment, you really should be commenting on why, not what. Andrew