Hi Greg A set of xhci changes for usb-next. Refactoring the xhci even thandling to simplify support for serveral xhci interrupters, and decoupling port resume handling from get_port_status xhci roothub request handling a bit. Thanks Mathias Mathias Nyman (11): xhci: fix event ring segment table related masks and variables in header xhci: remove xhci_test_trb_in_td_math early development check xhci: Refactor interrupter code for initial multi interrupter support. xhci: add helpers for enabling and disabling interrupters xhci: cleanup xhci_hub_control port references xhci: pass port pointer as parameter to xhci_set_port_power() xhci: move port specific items such as state completions to port structure xhci: Pass port structure as parameter to xhci_disable_port(). xhci: rename resume_done to resume_timestamp xhci: clear usb2 resume related variables in one place. xhci: decouple usb2 port resume and get_port_status request handling drivers/usb/host/xhci-debugfs.c | 2 +- drivers/usb/host/xhci-hub.c | 256 ++++++++++++------------ drivers/usb/host/xhci-mem.c | 338 +++++++++++--------------------- drivers/usb/host/xhci-ring.c | 81 ++++---- drivers/usb/host/xhci.c | 79 ++++++-- drivers/usb/host/xhci.h | 38 ++-- 6 files changed, 366 insertions(+), 428 deletions(-) -- 2.25.1