On 25/01/23 00:07, Geert Uytterhoeven wrote: > Use the new devm_of_phy_optional_get() helper instead of open-coding the > same operation. > > Signed-off-by: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> > --- > v2: > - Rebase on top of commit 854617f52ab42418 ("net: ethernet: ti: > am65-cpsw: Handle -EPROBE_DEFER for Serdes PHY") in net-next > (next-20230123 and later). > --- > drivers/net/ethernet/ti/am65-cpsw-nuss.c | 8 +++----- > 1 file changed, 3 insertions(+), 5 deletions(-) > > diff --git a/drivers/net/ethernet/ti/am65-cpsw-nuss.c b/drivers/net/ethernet/ti/am65-cpsw-nuss.c > index c696da89962f1ae3..794f228c8d632f7a 100644 > --- a/drivers/net/ethernet/ti/am65-cpsw-nuss.c > +++ b/drivers/net/ethernet/ti/am65-cpsw-nuss.c > @@ -1460,11 +1460,9 @@ static int am65_cpsw_init_serdes_phy(struct device *dev, struct device_node *por > struct phy *phy; > int ret; > > - phy = devm_of_phy_get(dev, port_np, name); > - if (PTR_ERR(phy) == -ENODEV) > - return 0; > - if (IS_ERR(phy)) > - return PTR_ERR(phy); > + phy = devm_of_phy_optional_get(dev, port_np, name); > + if (IS_ERR_OR_NULL(phy)) > + return PTR_ERR_OR_ZERO(phy); Reviewed-by: Siddharth Vadapalli <s-vadapalli@xxxxxx> Regards, Siddharth.