On Sat, Dec 03, 2022 at 06:25:46PM +0000, Christophe Leroy wrote: > > + > > +#ifdef CONFIG_USB > > +/* USB related modaliases can be split because of device number matching, so > > + * this function handles individual modaliases for one segment of the range. > > + */ > > +static ssize_t usb_id_to_modalias(const struct usb_device_id *id, > > + unsigned int bcdDevice_initial, > > No camelCase please. > > See https://docs.kernel.org/process/coding-style.html#naming This is a name that comes directly from the USB specification, and as such, those usages of CamelCase are allowed as they refer to well-known fields. But, the field is called bcdDevice, not bcdDevice_initial, so this could get a better name overall as it doesn't directly match up, so it should be changed to something a bit nicer. thanks, greg k-h