Fixes the bare use of 'unsigned' checkpatch warning by changing 'unsigned' to 'unsigned int'. Signed-off-by: Kushagra Verma <kushagra765@xxxxxxxxxxx> --- drivers/usb/serial/ark3116.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/usb/serial/ark3116.c b/drivers/usb/serial/ark3116.c index 39eaa7b97c40..6632f4280bbd 100644 --- a/drivers/usb/serial/ark3116.c +++ b/drivers/usb/serial/ark3116.c @@ -75,7 +75,7 @@ struct ark3116_private { }; static int ark3116_write_reg(struct usb_serial *serial, - unsigned reg, __u8 val) + unsigned int reg, __u8 val) { int result; /* 0xfe 0x40 are magic values taken from original driver */ @@ -90,7 +90,7 @@ static int ark3116_write_reg(struct usb_serial *serial, } static int ark3116_read_reg(struct usb_serial *serial, - unsigned reg, unsigned char *buf) + unsigned int reg, unsigned char *buf) { int result; /* 0xfe 0xc0 are magic values taken from original driver */ @@ -398,7 +398,7 @@ static int ark3116_tiocmget(struct tty_struct *tty) } static int ark3116_tiocmset(struct tty_struct *tty, - unsigned set, unsigned clr) + unsigned int set, unsigned int clr) { struct usb_serial_port *port = tty->driver_data; struct ark3116_private *priv = usb_get_serial_port_data(port); -- 2.36.1