On Mon, May 09, 2022 at 02:28:05PM +0800, Linyu Yuan wrote: > Take DECLARE_USB_FUNCTION_INIT(ffs, ffs_alloc_inst, ffs_alloc) as example, > it will generate function ffsmod_init/ffsmod_exit() > and variable ffsusb_func. I do not think "as example" is needed here, right? > Add possible character '_' in the macro which will generate > function/variable name in common format, ffs_mod_init/ffs_mod_exit() > and ffs_usb_func. Ok, but why do this? Why not add any other character? What problem does this solve? > > It will apply to all gadget functions which use this macro. That is a given for any macro, and you do nto needs to state this. > > Also do minor change accordingly to f_loopback.c and f_sourcesink.c. Why "also"? What minor change are you making and why? When you have "also" in a changelog text, that's a huge hint it should be more than one commit, and I think this should be more than one commit (hint, the f_loopback.c change can go first). > Signed-off-by: Linyu Yuan <quic_linyyuan@xxxxxxxxxxx> > --- > v2: fix issue report by kernel test robot <lkp@xxxxxxxxx> > > drivers/usb/gadget/function/f_loopback.c | 12 +----------- > drivers/usb/gadget/function/f_sourcesink.c | 6 +++--- > include/linux/usb/composite.h | 14 +++++++------- > 3 files changed, 11 insertions(+), 21 deletions(-) As the first version showed, you didn't test-build this so I really do not understand why it is needed as you obviously are not using this change anywhere.. Why the extra churn for no real advantage? thanks, greg k-h