On Fri, Oct 22, 2021 at 07:00:45PM +0800, dingsenjie@xxxxxxx wrote: > From: dingsenjie <dingsenjie@xxxxxxxxxx> > > Simplify the return expression in the tcpm.c Why? > > Signed-off-by: dingsenjie <dingsenjie@xxxxxxxxxx> Is this the full name you sign legal documents with? (I have to ask...) > --- > drivers/usb/typec/tcpm/tcpm.c | 5 +---- > 1 file changed, 1 insertion(+), 4 deletions(-) > > diff --git a/drivers/usb/typec/tcpm/tcpm.c b/drivers/usb/typec/tcpm/tcpm.c > index 22a85b396f69..dabe694a7eb1 100644 > --- a/drivers/usb/typec/tcpm/tcpm.c > +++ b/drivers/usb/typec/tcpm/tcpm.c > @@ -2766,14 +2766,11 @@ static int tcpm_set_charge(struct tcpm_port *port, bool charge) > > static bool tcpm_start_toggling(struct tcpm_port *port, enum typec_cc_status cc) > { > - int ret; > - > if (!port->tcpc->start_toggling) > return false; > > tcpm_log_force(port, "Start toggling"); > - ret = port->tcpc->start_toggling(port->tcpc, port->port_type, cc); > - return ret == 0; > + return port->tcpc->start_toggling(port->tcpc, port->port_type, cc) == 0; Why change this from the original code? The original code is easier to read, right? thanks, greg k-h