On Sat, Sep 11, 2021 at 01:26:31PM +0200, Len Baker wrote: > As noted in the "Deprecated Interfaces, Language Features, Attributes, > and Conventions" documentation [1], size calculations (especially > multiplication) should not be performed in memory allocator (or similar) > function arguments due to the risk of them overflowing. This could lead > to values wrapping around and a smaller allocation being made than the > caller was expecting. Using those allocations could lead to linear > overflows of heap memory and other misbehaviors. > > So, use the struct_size() helper to do the arithmetic instead of the > argument "size + count * size" in the kzalloc() function. > > [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments > > Signed-off-by: Len Baker <len.baker@xxxxxxx> > --- Acked-by: Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> > drivers/usb/host/ohci-hcd.c | 3 +-- > 1 file changed, 1 insertion(+), 2 deletions(-) > > diff --git a/drivers/usb/host/ohci-hcd.c b/drivers/usb/host/ohci-hcd.c > index 1f5e69314a17..666b1c665188 100644 > --- a/drivers/usb/host/ohci-hcd.c > +++ b/drivers/usb/host/ohci-hcd.c > @@ -191,8 +191,7 @@ static int ohci_urb_enqueue ( > } > > /* allocate the private part of the URB */ > - urb_priv = kzalloc (sizeof (urb_priv_t) + size * sizeof (struct td *), > - mem_flags); > + urb_priv = kzalloc(struct_size(urb_priv, td, size), mem_flags); > if (!urb_priv) > return -ENOMEM; > INIT_LIST_HEAD (&urb_priv->pending); > -- > 2.25.1 >