On 26.08.2021 20:39, Sergey Shtylyov wrote:
[...]
Two dev_info() calls in usb_hcd_request_irqs() have the same "io " strings
needlessly repeated. Merge these strings into the format strings of those
dev_info() calls...
Signed-off-by: Sergey Shtylyov <s.shtylyov@xxxxxx>
---
The patch is against the 'usb-next' branch of Greg KH's 'usb.git' repo...
drivers/usb/core/hcd.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Index: usb/drivers/usb/core/hcd.c
===================================================================
--- usb.orig/drivers/usb/core/hcd.c
+++ usb/drivers/usb/core/hcd.c
@@ -2730,16 +2730,16 @@ static int usb_hcd_request_irqs(struct u
return retval;
}
hcd->irq = irqnum;
- dev_info(hcd->self.controller, "irq %d, %s 0x%08llx\n", irqnum,
- (hcd->driver->flags & HCD_MEMORY) ?
- "io mem" : "io base",
- (unsigned long long)hcd->rsrc_start);
+ dev_info(hcd->self.controller, "irq %d, io %s 0x%08llx\n",
+ irqnum, (hcd->driver->flags & HCD_MEMORY) ?
+ "mem" : "base",
+ (unsigned long long)hcd->rsrc_start);
This now makes it harder to grep for messages in the kernel source :(
Mhm, maybe...
As this saves almost no memory, I'll just ignore this patch.
I also didn't find the current strings adequate -- I'd understand "io mem" vs "io port",
not what it is now...
Indeed, HCD_MEMORY means MMIO, else means I/O ports. Would the patch
fixing this substring be acceptable instead of this one?
thanks,
greg k-h
MBR, Sergey