On Fri, Nov 27, 2020 at 2:57 PM Guido Günther <agx@xxxxxxxxxxx> wrote: > > This allows downstream supplies and userspace to detect > whether external power is supplied. > + if (!(pwr_status & TPS_POWER_STATUS_CONNECTION) || > + !(pwr_status & TPS_POWER_STATUS_SOURCESINK)) { > + val->intval = 0; > + } else { > + val->intval = 1; > + } Can we please use positive conditionals (which usually are easier to read)? if ((pwr_status & TPS_POWER_STATUS_CONNECTION) && (pwr_status & TPS_POWER_STATUS_SOURCESINK)) { val->intval = 1; } else { val->intval = 0; } -- With Best Regards, Andy Shevchenko