Re: [PATCH 1/2] USB: Fix device driver race

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 20-07-22 17:53:25, Bastien Nocera wrote:
> On Wed, 2020-07-22 at 11:26 -0400, Alan Stern wrote:
> > On Wed, Jul 22, 2020 at 11:46:27AM +0200, Bastien Nocera wrote:
> > > When a new device with a specialised device driver is plugged in,
> > > the
> > > new driver will be modprobe()'d but the driver core will attach the
> > > "generic" driver to the device.
> > > 
> > > After that, nothing will trigger a reprobe when the modprobe()'d
> > > device
> > > driver has finished initialising, as the device has the "generic"
> > > driver attached to it.
> > > 
> > > Trigger a reprobe ourselves when new specialised drivers get
> > > registered.
> > > 
> > > Signed-off-by: Bastien Nocera <hadess@xxxxxxxxxx>
> > > ---
> > >  drivers/usb/core/driver.c | 31 +++++++++++++++++++++++++++++--
> > >  1 file changed, 29 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/drivers/usb/core/driver.c b/drivers/usb/core/driver.c
> > > index f81606c6a35b..a6187dd2186c 100644
> > > --- a/drivers/usb/core/driver.c
> > > +++ b/drivers/usb/core/driver.c
> > > @@ -905,6 +905,30 @@ static int usb_uevent(struct device *dev,
> > > struct kobj_uevent_env *env)
> > >  	return 0;
> > >  }
> > >  
> > > +static int __usb_bus_reprobe_drivers(struct device *dev, void
> > > *data)
> > > +{
> > > +	struct usb_device_driver *udriver = to_usb_device_driver(dev-
> > > >driver);
> > > +	struct usb_device *udev = to_usb_device(dev);
> > > +
> > > +	if (udriver == &usb_generic_driver &&
> > > +	    !udev->use_generic_driver)
> > > +		return device_reprobe(dev);
> > > +
> > > +	return 0;
> > > +}
> > > +
> > > +static int __usb_device_driver_added(struct device_driver *drv,
> > > void *data)
> > > +{
> > > +	struct usb_device_driver *udrv = to_usb_device_driver(drv);
> > > +
> > > +	if (udrv->match) {
> > > +		bus_for_each_dev(&usb_bus_type, NULL, udrv,
> > > +				 __usb_bus_reprobe_drivers);
> > 
> > What does udrv get used for here?
> > 
> > > +	}
> > > +
> > > +	return 0;
> > > +}
> > > +
> > >  /**
> > >   * usb_register_device_driver - register a USB device (not
> > > interface) driver
> > >   * @new_udriver: USB operations for the device driver
> > > @@ -934,13 +958,16 @@ int usb_register_device_driver(struct
> > > usb_device_driver *new_udriver,
> > >  
> > >  	retval = driver_register(&new_udriver->drvwrap.driver);
> > >  
> > > -	if (!retval)
> > > +	if (!retval) {
> > > +		bus_for_each_drv(&usb_bus_type, NULL, NULL,
> > > +				 __usb_device_driver_added);
> > 
> > This looks funny.  You're calling both bus_for_each_drv() and 
> > bus_for_each_dev().  Can't you skip this iterator and just call 
> > bus_for_each_dev() directly?
> 
> You're right, looks like this could be simplified somewhat. I'm
> building and testing a smaller patch.
> 

What do you mean "reprobe" for your device? Do you mean the mfi_fc_probe
is not called? If it is, Would you please check why usb_device_match
at drivers/usb/core/driver.c does not return true for your device?

-- 

Thanks,
Peter Chen



[Index of Archives]     [Linux Media]     [Linux Input]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Old Linux USB Devel Archive]

  Powered by Linux